quarta-feira, 29 de junho de 2011

Carros

Esse video do Top Gear mostra um carro que eu pilotei num Playstation 3 do @djlucianokuhnen. O jogo era o Gran Turismo 5. Acho que vale a pena ver um review do original.
Enjoy

Sugestão de filmes

Confesso que gosto destes filmes de fantasia. Principalmente os relacionados à mitologia (grega ou romana).


Esse não é um filme novo (animação), mas acho que vale a pena indicar.


Cowboys and Aliens. Confesso que no título achei que não valeria a pena, mas o trailer anima.


Novo Missão Impossível. Trailer promete.


Capitão América. Talvez "too American" mas tudo bem, gosto dos filmes Marvel too.

segunda-feira, 20 de junho de 2011

Manipulação de texto no Excel

Por recomendação do caro amigo @epsouza, vou mostrar algumas funções  para manipular textos e extrair valores dos mesmos.
Eu explico. Talvez você encontre uma tabela de dados ou apenas alguns números em algum site ou programa que gostaria de poder usar em sua planilha. Você de cara da um ctrl+c e depois um ctrl+v na sua planilha e pra sua surpresa, os dados não são colados como o desejado.
Como digitar dá trabalho e sempre vale a máxima "quando o crânio é fraco, o corpo padece". Sou arredio ao serviço braçal, portanto, vamos às fórmulas.

Como exemplo, infelizmente não vou usar maçãs, laranjas ou uma lista pequena comum nos tutoriais por aí. Vamos pra algo mais "hardcore".
Vou utilizar os dados da janela de texto do AutoCAD. Vou criar uma sequencia de retas no CAD, usar o comando "list" e manipular o resultado no Excel para extrair as coordenadas dos vértices. De quebra, desenhar no Excel estas mesmas linhas. Ousado? Também to achando hehe

Vamos lá. Primeiro o desenho.
Desenhei 6 retas aleatórias.

Em seguida, executamos o comando "list" e selecionamos as 6 linhas.
Com o F2, podemos abrir a janela com os dados.


Observe, que para deixar mais interessante nosso tutorial, o comando "list", interrompe a listagem por página, quebrando o que seria um padrão (a cada reta descrita em 7 linhas de texto) que facilitaria um pouco. O comando insere no final de cada página, um texto: "Press ENTER to continue:"
Pra nosso tutorial, isso serve perfeitamente.

Vamos agora abrir o Excel e colar este texto lá. Seleciona tudo, e com o famoso ctrl+c na janela do CAD e ctrl+v em uma planilha em branco no Excel, temos a seguir:


Clique entre o título de coluna A e B, para ajustar a largura (apenas para deixar mais organizado).

Na coluna B, criaremos nossa primeira fórmula. Nesta, vamos pesquisar quais linhas contém o texto "from". Com isso, saberemos que o X e o Y desta linha são o ponto de partida da reta.
A fórmula ficaria assim:

=PESQUISAR("from";A1)

Note que ela retorna um erro: #VALOR!
Isto ocorre pois na célula A1, não há o texto "from". Copie e cole a fórmula até a célula B5. O resultado #VALOR! se repete até a célula B4, mas na célula B5 retorna o valor 15. Ou seja, a letra "f" do texto "from" inicia-se no 15º caractere.


Uma forma que eu uso muito (apenas no Excel 2007/2010) para evitar os erros, é a função SEERRO.
Nossa fórmula ficaria assim:

=SEERRO(PESQUISAR("from";A1);"")   O string vazio "" como segundo argumento da função SEERRO, é o resultado que a fórmula irá retornar quando o primeiro argumento PESQUISAR("from";A1) retornar um erro.

Vamos agora identificar o texto "to point" criando uma fórmula parecida com a primeira na coluna C.


Pronto, agora temos identificadas as linhas onde estão os dados que queremos. Na verdade, eu poderia ter retornado um valor "VERDADEIRO"  ao invés da posição do texto (o 15 e o 17 indicados na figura), mas seria mais linha de comando a toa.

Vou utilizar uma coluna para cada fórmula, para não deixar muito extenso e não parecer mais complicado do que realmente é.

Bom, agora que sabemos qual linha contém os dados de origem e qual linha contém os dados de destino de cada segmento de reta, vamos identificar onde começa e onde termina, no texto, o X e o Y. Para saber onde termina o Y, vou procurar o início do Z. E o final do X, é o início do Y.

Vamos precisar de 3 colunas para origem e 3 colunas para destino encontrar estes 6 valores (em azul na figura acima).
Inseri 2 linhas antes da primeira linha, para dar espaço para os títulos das colunas, senão, começamos a nos perder.


Vou dar uma formatada pra não ficar muito "boca de porco" (jargão técnico). Apenas bordas e uma centralizada nos textos.



Agora vamos a algumas fórmulas:
Célula D3)     =SE(ÉNÚM($B3);PESQUISAR("X";$A3);"")
Célula E3)     =SE(ÉNÚM($B3);PESQUISAR("Y";$A3);"")
Célula F3)     =SE(ÉNÚM($B3);PESQUISAR("Z";$A3);"")
Célula G3)     =SE(ÉNÚM($C3);PESQUISAR("X";$A3);"")
Célula H3)     =SE(ÉNÚM($C3);PESQUISAR("Y";$A3);"")
Célula I3)     =SE(ÉNÚM($C3);PESQUISAR("Z";$A3);"")
Selecione a célula D3 até a I3 (D3:I3 na língua excel), copie e cole para baixo até o final do texto colado do CAD.

Mais uns ajustes... E teoricamente, a sua planilha, se estiver acompanhando, ficaria assim

Agora, nas colunas seguintes, digitemos:
Célula J3)     =SE(ÉNÚM(D3);EXT.TEXTO($A3;D3+2;E3-D3-2);"")
Célula K3)     =SE(ÉNÚM(E3);EXT.TEXTO($A3;E3+2;F3-E3-2);"")
Célula L3)     =SE(ÉNÚM(G3);EXT.TEXTO($A3;G3+2;H3-G3-2);"")
Célula M3)     =SE(ÉNÚM(H3);EXT.TEXTO($A3;H3+2;I3-H3-2);"")

Após colar essas fórmulas abaixo, deve obter um resultado assim: 

Como podemos observar, a partir deste momento, já temos os dados que queremos. Mas se tentarmos fazer alguma operação com eles, vamos perceber que ainda são textos. Para converter um texto em número, vamos utilizar o comando =VALOR(texto)
Antes, é necessário substituir o ponto decimal para vírgula.
Fazemos assim:

=SUBSTITUIR(J3;".";",")

Como podem observar, vai substituir o ponto "." pela vírgula "," no texto J3. Basta então, copiar para o lado e para baixo essa fórmula para funcionar para o resto.

Agora, pra não usarmos mais colunas, vou completar a fórmula anterior assim:

=SE(J3<>"";VALOR(SUBSTITUIR(J3;".";","));0)

ou assim:

=SEERRO(VALOR(SUBSTITUIR(J3;".";","));0)

O comando =SEERRO() foi incorporado no Excel 2007 em diante. Portanto, quem usar um Excel anterior, terá que usar a fórmula de cima.

Com isso, nossa planilha fica assim: 


Bom, acho que é isso. Eu pretendia ligar os pontos utilizando esse resultado, mas vou deixar pra outra postagem. Senão não termino essa e os comandos necessários, servem para outro assunto.

A planilha e o arquivo em CAD estão nesta pasta: Postagem 09 - Manipulação de texto no Excel.

Abraços

sábado, 18 de junho de 2011

Excel - Respondendo pergunta

O amigo Josiano Martins Sousa  perguntou pelo meu Orkut:

"Como pegar resultado de outra planilha e ficar em vermelho quando for negativo!"


Se eu entendi bem, podemos imaginar uma planilha com alguns cálculos e realizar uma formatação no resultado.
Primeiro, "pegar resultado de outra planilha", seria o vínculo entre planilhas

A melhor e mais prática forma de se vincular células entre planilhas, é simplesmente digitar o operador "=" e clicar na aba da outra planilha e depois na célula que contém o valor que se quer transportar.



No caso ao lado, a partir da Plan2, digitei o "=" e cliquei na célula A1 na Plan1. Pronto, só teclar "Enter" e seu valor foi transportado para na Plan2.




Já com relação a "ficar vermelho quando for negativo", há duas formas que eu utilizo.

A primeira e mais "correta" é usar a formatação da célula e formatar o número.


Pode-se utilizar o atalho ctrl+1 para abrir essa janela ou clicar com o botão direito sobre a planilha e selecionar "Formatar células..."
Observe que já existem as opções para formatar em vermelho (com ou sem sinal negativo), tanto para formatação como número ou como moeda.
Mas você só pode escolher o vermelho. Vamos tentar agora formatar em amarelo quando for negativo, sem utilizar a formatação condicional.


A formatação das duas células é a mesma. Pintei o fundo de cinza para ficar visível.
Para ter essa cor ou qualquer outra que desejar (e souber o nome), basta entrar em "Personalizado" e digitar a formatação do número como quer (número, moeda ou com algum complemento), depois digitar um ponto e vírgula e formatar como deseja que seja quando negativo. Para cores, digitar a cor que deseja entre [ ]

Uma última brincadeira. Quero que quando positivo, ele escreve o número formatado como moeda por metro quadrado. E quando for negativo, formate número em azul por kg.
Ficaria assim:

Para provar que não estou digitando a unidade e a formatação, recortei a imagem da barra de fórmulas, que demonstra o que está digitado na célula.
Note que coloquei fortamações diferentes de cada lado do ";". Isso diz ao Excel como proceder quando o número for maior que 0 e quando for menor que 0.

A outra forma que mencionei no início do tópico, é a formatação condicional. Não faz alteração como fizemos neste caso apresentado. Colocando unidades no número digitado, mas a gama de possibilidades de formatação são muito maiores. Podemos formatar a fonte, a cor do fundo, cor da borda, além da cor e forma das bordas.

Mas fica como assunto para um próximo tópico.

Abraços

quinta-feira, 16 de junho de 2011

Cálculo de Volume - 02

No post Cálculo de Volume - 01, iniciamos o cálculo do volume de cilindros "deitados".

Agora, nesta postagem, vamos demonstrar mais um passo do processo de cálculo.


Estas são as duas situações prováveis, e mais adiante vou explicar porque estou colocando estas duas situações.


Eu utilizo um método que acho bastante simples e bem eficaz. A área que queremos encontrar (Asec) é simplesmente esta Área 1 (A1), representada à esquerda, menos a Área 2 (A2) à direita.
Nossa primeira equação então: Asec=A1-A2

Mas para calcular essas áreas, precisamos definir mais algumas variáveis.


São elas:
Alpha = ângulo de abertura (conforme desenho)
b = metade da largura da lâmina d'água

Vou calcular A1 primeiro que é mais fácil. Depois partimos para a área do triângulo (A2)

Todos (ou quase) sabemos que a área da circunferência se dá por Acirc=pi*R^2
O que proponho é uma regra de 3. Isso mesmo, simples assim.
Portanto:



Agora que temos o A1, precisamos do alpha para descobrir o seu valor.
Utilizando as fórmulas trigonométricas aprendidas no primeiro grau (seno, cosseno e tangente), podemos extrair o alpha e o b:


Vou utilizar o cosseno pois como o alpha varia de 0 a 180 graus, o seno tem um comportamento que não nos serve.

Como podemos observar na figura, o seno varia de 0 a +1 e voltando a 0 para ângulos de 0 a 180 graus. Com isto, apresenta um mesmo valor para ângulos do primeiro e do segundo quadrante, o que para nós não seria possível distinguir entre eles pelo Arco Seno.
Já o cosseno varia de +1 a -1 para ângulos de 0 a 180 graus.

Ex: O seno de 45 graus é o mesmo do seno de 135 graus, que é 0,707107
      O cosseno de 45 graus é 0,707107 e o de 135 graus é -0,707107

Trigonometrias a parte, a equação para alpha fica assim:


E, usando o Teorema de Pitágoras, temos o b:


Agora, só nos resta encontrar a área 2 (A2) que é a área do triangulo formado entre o nível d'água e o centro da circunferência.

Para isso, usaremos a área de triângulo:

A mágica aqui é que, quando o nível d'água passar do meio, o A2 vai ficar negativo e assim, somar-se ao A1.
Para h<R: Asec=A1-A2
Para h>R: Asec=A1-(-A2) => Asec=A1+A2

Pronto! A partir deste ponto, qualquer um é capaz de calcular o volume. Basta fazer A1-A2.


Mas queremos uma única fórmula para esse cálculo. Então vamos começar a substituir o alpha em A1 e o b em A2.
Temos:

Vale lembrar que o alpha está calculado em radianos. Para calculadora em graus, deve-se multiplicar o alpha com pi e dividir por 180 graus. A equação ficaria assim:


Bom galera. É isso.

Para acesso aos arquivos desta publicação: 01 calculo volume tanque.

Valeu

Como preparar medalhão

Minha linda esposa me pergunta pelo gtalk, como deve fazer um medalhão.
Portanto, aqui vão as sugestões:


fonte: http://iniciantenacozinha.com


Medalhões de filé mignon

Fáceis de fazer e muito gostosos, esses medalhões foram um sucesso lá em casa.

INGREDIENTES

  • 1 peça de filé mignon
  • Sal (a gosto)
  • Pimenta do reino (a gosto)
  • Azeite de oliva
  • Manteiga com ervas (opcional)

PASSO A PASSO

  1. Primeiramente, e somente se for necessário, limpe o filé mignon para retirar qualquer gordura extra.
  2. Deixe-o no freezer para endurecer um pouco, isso facilita na hora de cortar os medalhões. Cuidado para a carne não congelar.
  3. Coloque cerca de 1 xícara de azeite de oliva em um prato fundo ou tigela.
  4. Corte os medalhões com uma largura de 2 centímetros.
  5. Jogue uma pitada de sal e outra de pimenta de cada lado do medalhão.
  6. Coloque uma frigideira ou chapa no fogo e deixe esquentar bem.
  7. Passe o medalhão no azeite de oliva e depois coloque-o para fritar. O que queremos aqui é selar a carne, ou seja, fritá-la de todos os lados para evitar que o suco saia dela. Então primeiro vamos fritar de um lado por alguns minutos, e depois do outro, selando a carne completamente. O tempo de fritura pode variar, dependendo de vários fatores: fogão, frigideira, grossura da carne, etc. O importante é continuarmos virando a carne até estar totalmente selada. Aí podemos retirar o medalhão (para quem gosta de carne mal passada) ou deixá-lo fritando mais um pouco, para que a carne fique bem passada.
  8. Para servir, coloque 1 colher de chá de manteiga com ervas finas (fácil de encontrar no mercado) ou manteiga comum mesmo sobre o medalhão e deixe derreter. Dá um visual muito legal!
Pra incrementar: frite fatias de bacon e sirva junto com os medalhões, também fica muito bom!
Esses medalhões vão muito bem com massas e um bom vinho. Eu os servi com uma lasanha e ficou ótimo. �? uma boa dica pra você que está pensando em fazer algo diferente pro dia dos namorados. Que tal inovar e cozinhar para o seu amado/amada?

Cálculo de volume - 01

Muitos de vocês deve olhar aquelas carretas de combustível cilíndricas ou aqueles grandes tanques de combustível de postos (os não enterrados) e ficam imaginando "como fazem para saber quantos litros tem ali dentro?" #not
Claro que se o tanque estiver cheio até a boca, a fórmula do pi*r^2*comprimento resolve a situação a contento. Mas e se não estiver completamente cheio?

Hoje em dia, todos os postos de combustível medem seus reservatórios enterrados com uma régua e depois checam a medida em uma tabela pronta. Mas e de onde saiu essa tabela?

Essa equação me chamou a atenção enquanto eu ainda era uma criança e via meu pai e meu tio "apertando" um primo meu que era engenheiro civil. Lembro exatamente meu pai deitando uma garrafa e questionando esse primo meu como saber quando havia ali dentro. Meu primo deu uma pensada. Havia um amigo dele junto que também era engenheiro. Trocaram olhares e concordaram que a melhor forma seria por integral. Mas não deram a solução. E ficou por isso mesmo. Na época não sabia o que era a tal "integral". Hoje sei que eles queriam dizer uma integral tripla, utilizada em cálculos de volume. A primeira integral variando de 0 a pi. A segunda de 0 ao raio e a terceira de 0 ao comprimento.

Mas deixemos isso pra lá. Nem eu saberia agora montar essa integral agora sem passar uma semana ao menos relembrando tudo.

Vou apresentar uma "montagem" de equações simples e conhecidas (e o mais didático possível) para que cheguemos na tal equação.

A primeira coisa, é definir o que teremos de dados de um tanque destes:



R = Raio interno do tanque
h = Altura da lâmina d'água (ou o líquido que for)
L = Comprimento interno do tanque (não representado aqui)



A área que queremos calcular é esta Asec (área da seção). Com essa área em mãos, basta multiplicar pelo comprimento do tanque que teremos seu volume (Asec*L)

Iniciarei os cálculos no próximo post. Lápis e papel na mão ;)

Calculo de Volume 02

quarta-feira, 15 de junho de 2011

Vontades

To com tesão de escrever algumas fórmulas matemáticas. Primeiro pra exercitar e outra que é pra ficar o histórico.
E outra coisa, é seguir a sugestão do amigo @epsouza e falar sobre Excel...

To animado ainda com isso aqui

Mania Zoombie

Acho que depois do filme A Volta dos Mortos Vivos (sim, eu assisti na época do lançamento), o assunto "zumbis" nunca mais deixou de ser moda.
Por último, com grande sucesso, a sequência Resident Evil - game e filme - consegue manter o assunto em alta e dar novo gás para o assunto.
Mas não é só nas telonas. Ano passado foi lançada uma série para a tv chamada The Walking Dead.
O próprio ator que faz o protagonista, quando foi convidado, chegou a imaginar que seria um "barco furado", um declínio pra sua carreira participar de uma série sobre zumbis. Mas o que aconteceu foi o oposto. A primeira temporada, com 6 episódios fez muito sucesso.

Mas eu comecei a escrever esse post pra falar dos programas para celular que apareceram com esse assunto zumbi.

Recentemente, por sugestão do amigo Thiago Camargo (@thgcamargo), instalei para meu Android o software ZombieBooth
Além de ser um sarro zoar com os amigos, ele faz uma coisa que acho incrível, que é reconhecer a face, aplicar os efeitos e dar movimento à foto. Coisas que a pouco tempo atrás só seria possível em computadores bem dotados de processamento.

Seguem algumas fotinhas extraídas do programa: (será que identifico quem é quem nas fotos? Só depois que eu consultar meus advogados hehe)
Podemos também fazer um jogo e tentar descobrir quem são :)

Este é um "Cara"muito conhecido e famoso
no meio empresarial.
Incrível como ele consegue movimentar
as sobrancelhas

Mais uma variação. Já ta ficando fácil acertar
quem é
Além da opção de vários padrões de zumbi.

 Esse cara é conhecido também.
Só posso dizer que mora junto com o primeiro.
(entenda morar junto como quiser)

Essa daqui nao posso dizer quem é,
mas o efeito ficou bom.
Nem fiz gracinha... senão...



E este é quem vos fala.

Sou péssimo pra tirar fotos, mas aqui até gostei





Uma pena o programa nao colocar cabelo. Se bem que para a interpretação de zumbi, meu penteado caiu bem :)

terça-feira, 14 de junho de 2011

Equações

Antes de criar o blog, fiquei imaginando o que iria postar. Mas daí imaginei que talvez postar de tudo um pouco fosse legal, e quem sabe mais adiante eu nao acabe descobrindo algum assunto que eu discorra mais?

Mas antes, imaginei postar sobre viagens, trilhas, motos/carros, engenharia, lutas (leia-se karate)... ou qualquer coisa que eu tenha algum conhecimento. Por isso o "Viva a Diversidade"
Mas confesso que nao gostei muito do nome... fazer o que.

Entao vamos lá. O que vier de agora em diante, é lucro :)

Nomes

Pra tudo temos nomes ou abreviações em siglas... pra criar esse blog ja deu um trampo danado pra escolher um nome que nao estava em uso.
No final, acabou vencendo o meu nick que eu usava pra jogar Age Of Empires...

No final, o que vence é a tradiçao :)